DocuWorks Viewer Light 9.0.3 リリースノート

2018年11月
富士ゼロックス株式会社

本書の内容を正しく表示できない場合は、新しいバージョンのWebブラウザー(以降、ブラウザー)でごらんください。
DocuWorks Viewer Light 9.0.3、またはDocuWorks Viewer Light for Web 9.0.3をご使用いただくための情報を説明します。
Microsoft® Windows® 7の操作を例に記述しています。
Microsoft® Windows® 7以外のオペレーティングシステム(以降、OS)をお使いのかたは、環境に合わせて読み替えてください。

目次
1. 概要
2. DocuWorks Viewer Light 9の新機能
3. 変更点
4. 複製と頒布について
5. DocuWorks Viewer Light for Webが動作するブラウザーについて
6. Microsoft® Windows® 7 / Windows® 8.1 / Windows® 10の保護モードによるDocuWorks Viewer Light Controlの操作制限と回避方法
7. インストールについて
8. サイレントインストールについて
9. インストールのカスタマイズについて
10. アンインストールについて
11. 起動と終了
12. DocuWorks Viewer Light for Webの操作について
13. 注意と制限
14. DocuWorks Content Filter 8について
15. 情報入手先
16. その他

1.概要


1-1. DocuWorksとは

DocuWorksとは、オフィスのさまざまな場面で作成されたアプリケーションデータ、ファクスデータ、スキャンデータなどを区別なく扱い、さまざまな文書データの処理を同一画面で行えるドキュメントハンドリングソフトウェアです。
DocuWorksに関する情報については、「 15. 情報入手先 」を参照してください。

1-2. DocuWorks Viewer Lightの概要

DocuWorks Viewer Lightは、DocuWorks Viewerの簡易版です。 DocuWorksをインストールしていない環境で、DocuWorksファイル(DocuWorks文書、DocuWorksバインダー、およびDocuWorks入れ物)を表示できます。編集はできません。
DocuWorks Viewer Lightでは、DocuWorksファイルの文字列の検索やコピー、リンクアノテーションによるジャンプ、オリジナルデータまたは内容物の取り出しなどができます。DocuWorks文書とDocuWorksバインダーは、印刷ができます。
DocuWorks Viewer Lightには、通常版と、文書情報の持ち出し操作を制限した制限版の2つがあります。通常版の実行ファイル名は「dwvlt.exe」、制限版の実行ファイル名は「dwsvlt.exe」です。2つとも同じフォルダーにインストールされます。

1-3. DocuWorks Viewer Light for Webの概要

DocuWorks Viewer Light for Webは、Webブラウザー(以下、ブラウザー)にDocuWorksファイルを表示します。ホームページ上のDocuWorksファイルや、ホームページに埋め込まれたDocuWorksファイルを表示できます。編集はできません。
DocuWorksファイルの文字列の検索やコピー、リンクアノテーションによるジャンプ、オリジナルデータまたは内容物を取り出すことなどができます。DocuWorks文書とDocuWorksバインダーは、印刷ができます。
また、バイトサービング機能とActiveX®コントロールに対応しています。

1-4. DocuWorks Viewer Light(文書情報持ち出し操作制限版)とは

DocuWorks Viewer Light (文書情報持ち出し操作制限版) とは、DocuWorks Viewer Light から印刷や文書の内容をコピーする機能などを取り除き、閲覧機能に特化したものです。
DocuWorks Viewer Light (文書情報持ち出し操作制限版) は、Windows®のスタートメニューやエクスプローラなどからは起動できません。連携するソフトウェアから起動されます。なお、連携するソフトウェアからの制御により、リンクアノテーションによるジャンプを制限することも可能です。

DocuWorks Viewer Light (文書情報持ち出し操作制限版) と連携するソフトウェア商品には、次のものがあります。
  • 日立ソフトウェアエンジニアリング株式会社
    秘文® Advanced Edition 07-50以降

2. DocuWorks Viewer Light 9の新機能


3. 変更点


9.0.2から9.0.3への変更点


9.0.0から9.0.2への変更点


4. 複製と頒布について

DocuWorks Viewer Lightは、お客様が複製や頒布をすることができます。
この場合、DocuWorks Viewer Lightのソフトウェア、インストーラー、このリリースノート、および著作権・登録商標の情報を含んで複製する必要があります。
弊社より提供しているインストーラープログラムを変更したり、独自に作成したりすることは固く禁じられています。

5. DocuWorks Viewer Light for Webが動作するブラウザーについて

DocuWorks Viewer Light for Webが動作するブラウザーは、次のとおりです。 補足
Windows® Internet Explorer® 11では、ActiveX®コントロールを使用して表示します。

6. Microsoft® Windows® 7 / Windows® 8.1 / Windows® 10の保護モードによるDocuWorks Viewer Light Controlの操作制限と回避方法


6-1. 操作の制限

次の制限があります。
  • 開くパスワードが設定されている保護文書を開くときに、パスワードの一時記憶が使用できません。文書を開くときは、常にパスワードの入力が必要です。
  • 電子印鑑による保護文書を表示できません。
  • 電子証明書による保護文書を表示できません。
  • 署名の検証ができません。
  • [DocuWorks Viewer Light Controlの設定]の[一時ファイルの場所]で、任意のフォルダーを設定できません。
  • [DocuWorks Viewer Light Controlの設定]が、保護モードが有効のときと無効のときでは、別に設定されます。
  • DocuWorks Viewer Light Controlの印刷設定が、保護モードが有効のときと無効のときでは、別に設定されます。

6-2. 回避方法

以下のいずれかの方法を実施したのち、ファイルを表示してください。
  • Windows® Internet Explorer®の[インターネットオプション]で、保護モードを一時的に無効にする。
  • Windows® Internet Explorer®の[インターネットオプション]で、サーバーを信頼済みサイトに追加する。
  • DocuWorksファイルをダウンロードする。

7. インストールについて


7-1. インストールに必要な環境

DocuWorks Viewer LightおよびDocuWorks Viewer Light for Webをインストールするには、お使いのコンピューターに次のシステムが必要です。
OS*1 Windows® 10(32ビット)
Windows® 10(64ビット)
Windows® 8.1 Update(32ビット)
Windows® 8.1 Update(64ビット)
Windows® 7(32ビット)[Service Pack 1]
Windows® 7(64ビット)[Service Pack 1]
CPU*2 1 GHz以上の32ビット(x86)プロセッサー、または64ビット(x64)プロセッサー
ハードディスク容量*2 インストール時は1.5 GB以上の空き容量が必要
実際の操作には、加えて200 MB以上の空き容量を推奨
メモリー容量*2 32ビットOSの場合、1 GB以上
64ビットOSの場合、2 GB以上
ディスプレイ*2 1,280×768ピクセル以上、フルカラー
Webブラウザー Internet Explorer® 11
必要なハードウェア メディアからインストールする場合は、DVD-ROMドライブが必要
必要なソフトウェア インデクシングを用いた高速検索機能を利用する場合は、Windows® Search 4.0が必要です。
*1: 最新の対応OSについては富士ゼロックス公式サイトをご覧ください。
*2: OSの推奨値に準拠します。

7-2. インストール時の注意事項

  • DocuWorks Viewer LightおよびDocuWorks Viewer Light for Webをインストールする前に、起動しているほかのアプリケーションを終了してください。
  • インストールするユーザーにAdministratorと同等の権限が必要です。
  • DocuWorksがすでにインストールされている環境では、DocuWorksファイルのアプリケーションへの関連づけは変更されません。DocuWorks Viewer Lightをインストールしたあとに、DocuWorksをインストールした場合、DocuWorksファイルのアプリケーションへの関連づけは、DocuWorksに変更されます。
  • 古いバージョンのDocuWorks Viewer Light for Webがインストールされている場合は、上書きインストールしてください。

7-3. インストール手順

  1. 「Setup.exe」を実行します。
    DocuWorks Viewer Lightのインストーラーが起動します。
  2. インストールする言語を選択し、[OK]をクリックします。
  3. [DocuWorks Viewer Light 9のセットアップウィザードへようこそ]ダイアログボックスで、[次へ]をクリックします。
    [使用許諾契約]ダイアログボックスが表示されます。
  4. 使用許諾契約の内容を確認します。
    [使用許諾契約の条項に同意します]を選択して、[次へ]をクリックします。
    [セットアップタイプ]ダイアログボックスが表示されます。
  5. 標準設定でインストールする場合は、[標準]を選択して[次へ]をクリックします。手順7に進みます。
    インストール先とオプション設定を選択してインストールする場合は、[カスタム]を選択して[次へ]をクリックします。手順5に進みます。
  6. [インストール先のフォルダ]ダイアログボックスの[DocuWorks Viewer Light 9のインストール先]を確認します。インストール先を変更する場合は、[変更]をクリックしてインストール先を指定します。
    [次へ]をクリックします。
    [ブラウザ上での表示設定]ダイアログボックスが表示されます。
  7. Windows® Internet Explorer®上でDocuWorks文書を表示する場合は、[Windows Internet Explorer]にチェックマークを付けます。
    [次へ]をクリックします。
  8. [プログラムをインストールする準備ができました]ダイアログボックスの設定内容を確認して、[インストール]をクリックします。
    インストールが開始されます。
    インストールが完了すると、[セットアップウィザードを完了しました]ダイアログボックスが表示されます。
  9. [完了]をクリックします。

8. サイレントインストールについて

DocuWorks Viewer Lightは、サイレントインストールができます。サイレントインストールではインストールウィザードが表示されず、ユーザーの操作なしにインストールが完了します。サイレントインストールは、多数のPCに一度にインストールする場合に便利です。
サイレントインストールでは、インストール先フォルダーやDocuWorks Viewer Light Controlの使用の設定には初期値が使用されます。これらの設定は、「9. インストールのカスタマイズについて」で説明する方法を使って、カスタマイズすることもできます。

8-1. サイレントインストールの方法

サイレントインストールを実行する方法には、次の2種類があります。
  • 「Setup.exe」コマンドに/sオプションを付けて実行する方法
  • 「dwvlt.ini」ファイルを編集して「Setup.exe」を実行する方法

8-2. 「Setup.exe」コマンドに/sオプションを付けてサイレントインストールを実行する

コマンドプロンプトやバッチファイルなどで「Setup.exe /s」を実行します。

8-3. 「dwvlt.ini」ファイルにサイレントインストールの設定を記述する

「Setup.exe」と同じフォルダーに、「dwvlt.ini」という名前のテキストファイルを作成し、このファイルにサイレントインストールの設定を記述して、「Setup.exe」を実行します。
  1. 「dwvlt.ini」ファイルをテキストエディターで開き、次のセクションを追加します。
    [Install]
    SilentInstall=Y

    注記
    「dwvlt.ini」ファイルは、文字コードをUnicodeで作成します。編集には、文字コードをUnicodeで保存できるアプリケーションを使用してください。
  2. 「dwvlt.ini」ファイルの変更を保存し、「Setup.exe」を実行します。

8-4. サイレントインストールした場合の使用許諾契約について

サイレントインストールした場合は、DocuWorks Viewer Lightを最初に起動したとき、使用許諾契約書が表示されます。

9. インストールのカスタマイズについて

インストール先フォルダー、DocuWorks Viewer Light Controlの使用などの選択をカスタマイズできます。カスタマイズは、通常のインストールとサイレントインストールのどちらにも適用されます。

9-1. インストールのカスタマイズ用設定ファイルを作成する

「Setup.exe」と同じフォルダー内に、「dwvlt.ini」という名前のテキストファイルを作成し、インストール時の設定内容を記述します。このファイルの記述に従ってインストールされます。
カスタマイズ用設定ファイルを「Setup.exe」が格納されているフォルダーとは別のフォルダーに配置する場合は、「Setup.exe」コマンドに /o オプションを付けて、インストールのカスタマイズ設定用ファイルのフルパスを指定して実行します。

Setup.exe /o "インストールのカスタマイズ用設定ファイルのフルパス"

9-2. インストールのカスタマイズ用設定ファイルの書式

通常のWindowsのiniファイルと同じ書式です。キーと値は「=(等号)」で結び、同一行に記述します。
[セクションネーム1]
キー1=値1
キー2=値2
[セクションネーム2]
キー1=値1
キー2=値2
  • 「セクションネーム」は、インストール時に表示されるダイアログボックス、またはダイアログボックスに属さないインストールの設定に対応します。
  • 「キー」は、ダイアログボックスの設定項目、またはダイアログボックスに属さないインストールの設定に対応します。
  • 「値」は、設定項目に指定する内容に対応します。

9-3. セクションネーム

セクションネームの意味、対応するダイアログボックスまたはインストールの設定は、次のとおりです。
セクション
ネーム
説明
InstFolder [インストール先のフォルダ]ダイアログボックスに対応します。
ViewerLightControl [ブラウザでの表示設定]ダイアログボックスの[Windows Internet Explorer]に対応します。

9-4. キー

セクションごとのキーと値は、次のとおりです。記述がない場合、および不正な値が設定されている場合は、初期値が適用されます。
  • [InstFolder]セクション
  • キー 説明
    Path インストール先
    フォルダーパス
    インストール先のフォルダーをフルパスで設定します。
  • [ViewerLightControl]セクション
  • キー 説明
    Use Y(初期値) [使用する]が選択されます。
    N [使用しない]が選択されます。

9-5. 「dwvlt.ini」ファイルに再起動の設定を記述する

「Setup.exe」と同じフォルダーに、「dwvlt.ini」という名前のテキストファイルを作成し、このファイルに再起動の設定を記述して、「Setup.exe」を実行します。
  1. 「dwvlt.ini」ファイルをテキストエディターで開き、次のセクションを追加します。
    [Finish]
    Reboot=Y

    注記
    Rebootキーを指定しなかった場合、インストール後に再起動が必要な場合にのみ再起動が行われます。再起動したくない場合は、「Reboot=N」と記述してください。
    「dwvlt.ini」ファイルは、文字コードをUnicodeで作成します。編集には、文字コードをUnicodeで保存できるアプリケーションを使用してください。
  2. 「dwvlt.ini」ファイルの変更を保存し、「Setup.exe」を実行します。

10. アンインストールについて

アンインストールとは、インストール時に作成したファイルを削除することです。

10-1. アンインストール時の注意事項

  • ユーザーがインストールディレクトリー内に作成したファイルは削除されません。
  • アンインストールするユーザーにAdministratorと同等の権限が必要です。

10-2. アンインストール手順

  1. タスクバーの[スタート]をクリックし、[コントロールパネル]を選択します。
  2. [プログラムのアンインストール]をクリックします。
  3. [プログラムと機能]画面で、[Fuji Xerox DocuWorks Viewer Light 9]を選択し、[アンインストール]をクリックします。
  4. アンインストールを確認するダイアログボックスで[はい]をクリックします。
  5. [ユーザーアカウント制御]ダイアログボックスが表示された場合は、[はい]をクリックします。
    アンインストールが完了します。

11. 起動と終了


11-1. DocuWorks Viewer Lightの起動と終了

DocuWorks Viewer Lightのメニューやダイアログボックスについては、[ヘルプ]メニューの[DocuWorks Viewer Light ヘルプ]を選択して、『ヘルプ』を参照してください。

11-1-1. 起動手順

[スタート]、[すべてのプログラム]、[Fuji Xerox]、[DocuWorks]、[DocuWorks Viewer Light]の順に選択します。
DocuWorks Viewer Lightのウインドウが表示されます。
または、DocuWorksファイルをダブルクリックすると、DocuWorks Viewer Lightが自動的に起動します。

11-1-2. 終了手順

[ファイル]メニューの[DocuWorks Viewer Lightの終了]を選択します。

11-2. DocuWorks Viewer Light for Webの起動と終了


11-2-1. 起動手順

ブラウザーウインドウにDocuWorksファイルを表示すると、DocuWorks Viewer Light for Webが起動します。
ブラウザーウインドウにDocuWorksファイルを表示する方法は、次のとおりです。
  1. HTML内のアンカータグ<a>で指定されたDocuWorksファイルを選択します。
  2. ブラウザーの、アドレスを指定するフィールドに、DocuWorksファイルのURLを入力します。
  3. ブラウザーの[ファイル]メニューで、DocuWorksファイルを指定して開きます。
  4. ブラウザーウインドウに、DocuWorksファイルをドラッグ&ドロップします。
また、DocuWorksファイルを埋め込んだHTMLファイルを表示すると、DocuWorksファイルが埋め込み表示されます。
URLやHTMLの指定方法については、「 12-22. DocuWorksファイルを表示する場合のURLやHTMLの指定について 」を参照してください。

11-2-2. 終了手順

ブラウザーを終了したり、別のHTMLファイルを表示したりすると、DocuWorks Viewer Light for Webは終了します。

12. DocuWorks Viewer Light for Webの操作について


12-1. ウインドウの各部について

表示ウインドウには、DocuWorksファイルの内容が表示されます。

12-1-1. ウインドウの表示形式

全画面表示と埋め込み表示の2種類があります。
全画面表示は、ブラウザーウインドウ全体にDocuWorksファイルのページ内容が表示されます。
埋め込み表示は、HTML文書内に埋め込んだDocuWorksファイルの場合の表示形式です。イメージファイルを埋め込んだ場合のように、HTMLページの一部として表示されます。
全画面表示のウインドウには、標準ツールバー、DocuWorksバインダーの索引ツールバー、ステータスバーがあります。それぞれ、ポップアップメニューで表示/非表示を切り替えられます。

12-1-2. ツールバー

ツールバーには、標準ツールバーとDocuWorksバインダーの索引ツールバーがあります。ツールバーは、全画面表示のときに表示されます。
標準ツールバーと、DocuWorksバインダーの索引ツールバーは、ドラッグすると表示位置を入れ替えることができます。
標準ツールバーには、次の項目があります。
[複製を保存]、[印刷]、[検索]、[前を検索]、[次を検索]、[右90度回転]、[部分イメージコピー]、[スクロールモード]、[テキスト選択モード]、[最初のページ]、[前のページ]、[次のページ]、[最後のページ]、[ページ指定]、[縮小]、[ページ幅を基準]、[拡大]、[アノテーション表示/非表示切り替え]、[オリジナルデータの取り出し]
DocuWorksバインダーの索引ツールバーには、DocuWorksバインダーを表示しているときに、DocuWorksバインダー内の文書の一覧が表示されます。
ツールバーの位置を移動して、ウインドウを終了すると、次回起動時にその位置で表示されます。

12-1-3. ポップアップメニュー

表示ウインドウで、マウスの右ボタンをクリックすると、ポップアップメニューが表示されます。
ポップアップメニューには、次の項目があります。
  • [ファイル]
    • [複製を保存]
    • [印刷]
  • [編集]
    • [コピー]
    • [すべて選択](テキスト選択モードのとき)
    • [回転]
    • [検索]、[前を検索]、[次を検索]
  • [表示]
    • [標準ツールバー]
    • [バインダーの索引ツールバー]
    • [ステータスバー]
    • [アノテーション表示]
    • [表示ページプロパティ]
    • [署名の一覧を表示]
    • [OCR結果の表示]
    • [スクロールモード]
    • [テキスト選択モード]
    • [部分イメージコピー]
    • [Webブラウザーを起動]
  • [文書]
    • [文書プロパティ]
    • [オリジナルデータの取り出し]
    • [署名の状態を表示]
  • [最初のページ]、[前のページ]、[次のページ]、[最後のページ]、[ページ指定]
  • [倍率]
  • [文書の表示位置]
    • [左上を表示]、[右上を表示]、[左下を表示]、[右下を表示]
    • [現在の表示位置を保存]
      • [左上を原点]、[右上を原点]、[左下を原点]、[右下を原点]
      • [設定をリセット]
  • [DocuWorks Viewer Light Controlの設定]
  • [ヘルプ]
    • [Fuji Xerox Webページ]
    • [バージョン情報]

12-1-4. ステータスバー

ステータスバーには、表示されている文書の表示ページと総ページ数、表示倍率、文書が保護されているかいないかが表示されます。DocuWorksバインダーを表示している場合は、「バインダー」と表示されます。保護文書を表示している場合は、錠の形をしたアイコンが表示されます。
また、選択しているツールバーのボタンやポップアップメニューの説明が表示されます。

12-2. DocuWorks Viewer Light for Webの設定

ポップアップメニューから、[DocuWorks Viewer Light Controlの設定]を選択して表示されるダイアログボックスで、通信に関する設定と一時ファイルに関する設定、標準の表示倍率の設定、部分イメージ選択の設定ができます。
通信タブの詳細は、「 12-20 バイトサービング機能について 」を参照してください。
表示タブの詳細は、「 12-5 表示倍率の変更」を参照してください。
部分イメージ選択タブの詳細は、「 12-15 部分イメージコピー 」を参照してください。

12-3. ページめくり

次の方法で、ウインドウに表示されているページをめくることができます。
  • 標準ツールバーのボタンをクリックします。
  • ポップアップメニューを選択するか、または対応するショートカットキーを押します。
  • ホイールマウスの場合<shift>キーを押しながらホイールを前後に回転します。前に回転すると前のページ、後ろに回転すると次のページが表示されます。
スクロールめくりにするには、<shift>キーを押しながら<page up>キーまたは<page down>キーを押してページをめくります。
スクロールめくりは、前のページを指示すると、ページの下の部分が表示され、次のページを指示すると、上の部分が表示されるようにスクロールしてページをめくります。スクロールめくりは、全画面表示のときにできます。
標準ツールバー/ポップアップメニューの[ページ指定]を選択すると、表示するページを指定できます。
また、DocuWorksバインダーの索引ツールバーで、DocuWorksバインダー内の表示する文書を切り替えることができます。
[DocuWorks Viewer Light Controlの設定]を選択して表示されるダイアログボックスの[文書を厚み表示にする]にチェックマークを付けると、ページからはみ出した付箋でページをめくることができます。

12-4. スクロール

標準ツールバー/ポップアップメニューの[スクロールモード]を選択すると、カーソルが手の形になります。マウスの左ボタンを押しながらカーソルを動かすと、表示ページを上下左右にスクロールできます。 また、マウスのホイールの操作でスクロールすることができます。
<F4>を押すと、スクロールモードとテキスト選択モードが交互に切り替わります。

12-5. 表示倍率の変更

次の方法で、表示倍率を変更できます。表示倍率の設定は、文書を閉じるときには保存されません。
  • 標準ツールバーのボタンをクリックします。
  • ポップアップメニューを選択するか、または対応するショートカットキーを押します。
  • ホイールマウスの場合、<Ctrl>キーを押しながらホイールを前後に回転します。前に回転すると10%きざみで縮小、後ろに回転すると10%きざみで拡大されます。
標準ツールバーの[拡大]/[縮小]およびポップアップメニューの[倍率]による表示倍率は、17%、33%、67%、100%、133%、167%、200%、300%、400%の9段階です。
標準ツールバー/ポップアップメニューの[ページ幅を基準]は、現在のウインドウの幅の左右に約1cmの余白を設け、残りの幅にページの幅を合わせた表示倍率になります。ウインドウサイズを変更すると、ページの表示倍率が新しいウインドウサイズに合わせて変更されます。
ポップアップメニューの[ページの高さを基準]は、現在のウインドウの高さの上下に約1cmの余白を設け、残りの高さにページの高さを合わせた表示倍率になります。[ページ全体を表示]は、ページのたて横とも、現在のウインドウに収まる表示倍率になります。
HTML文書内に埋め込んだDocuWorksファイルは、HTMLで指定したサイズで表示されます。指定できる倍率は10~1600%です。また、ポップアップメニューの[ブラウザー全体で表示]を選択して、ブラウザーのウインドウ全体に表示できます。
文書を表示するときの最初の表示倍率は、ポップアップメニューから、[DocuWorks Viewer Light Controlの設定]を選択して表示されるダイアログボックスで設定できます。ここで設定した内容は、次回起動時から有効になります。

12-6. 文書の表示位置の設定

DocuWorks Viewer Light Controlで表示する、文書の位置を設定できます。この機能は、複数の文書の同じ位置を、DocuWorks Viewer Light Controlで連続して表示する場合に利用できます。

補足
[倍率]で[ページ幅を基準]、[ページ高さを基準]、または[ページ全体を表示]が選択されている場合は、[倍率]の設定が優先されます。

12-6-1. 文書の左上/右上/左下/右下を表示する

ポップアップメニューの[文書の表示位置]から、[左上を表示]、[右上を表示]、[左下を表示]、または[右下を表示]を選択します。
選択した表示位置には、チェックマークが付きます。

12-6-2. 現在の表示位置を保存する

文書をスクロールして、左上、右上、左下、または右下とは別の位置を表示している場合、その表示位置を保存すると、DocuWorks Viewer Light Controlで別の文書を表示したときも、保存した位置が表示されます。たとえば「文書の右下から左方向に10cm、上方向に12cm」のような位置を、複数の文書で連続して表示したいとき、[右下を原点]に設定します。この設定は、DocuWorks Viewer Light Controlを終了しても保存されます。

補足
表示位置を保存しない場合、別の文書を表示すると、[左上を表示]、[右上を表示]、[左下を表示]、または[右下を表示]のうち、チェックマークが付いている位置が表示されます。

現在の表示位置を保存するには、ポップアップメニューの[文書の表示位置]、[現在の表示位置を保存]の順に展開し、[左上を原点]、[右上を原点]、[左下を原点]、または[右下を原点]を選択します。
選択した原点からの、表示位置の座標が保存されます。原点にした左上/右上/左下/右下から内側が、座標の正方向になります。

補足
[現在の表示位置を保存]から[設定をリセット]を選択すると、[左上を表示]が選択され、原点も左上になります。

12-7. 表示ページの回転

ポップアップメニューの[編集]の[回転]から、[右90度]、[左90度]、[180度]を選択して、表示ページを回転できます。また、ツールバーの[右90度回転]ボタンを選択すると、表示ページを90度回転できます。ただし、回転の結果は、文書を閉じるときには保存されません。
アノテーションが貼り付けられているページは回転できません。
文書編集が禁止されている保護文書の場合は、回転できません。
署名が貼り付けられているページは回転できません。

12-8. アノテーションの表示/非表示の切り替え操作

標準ツールバー/ポップアップメニューの[アノテーション表示]を選択して、文書に貼り付けられているアノテーションを表示するかしないかを切り替えられます。
アノテーションを非表示にすると、アノテーションは印刷されません。
アノテーションの操作の詳細は、「 12-9 リンク先への移動 」を参照してください。
アノテーション編集が禁止されている保護文書の場合は、アノテーションの表示状態を切り替えることはできません。
署名文書の場合は、アノテーションの表示状態を切り替えることはできません。

12-9. リンク先への移動

DocuWorksファイルに貼り付けられているリンクアノテーションからリンク先へジャンプできます。
リンクアノテーション上にカーソルを移動すると、カーソルの形が変わります。マウスの左ボタンをクリックすると、リンク先へジャンプします。
設定内容 動作
Webページへのリンク ブラウザーが起動して、Webページが表示されます。
DocuWorksファイルへのリンク 指定ページが表示されます。指定ページを表示できない場合は、メッセージが表示され、先頭ページが表示されます。
他のファイルへのリンク 指定したファイルが関連付けされたアプリケーションで開きます。
メールアドレスへのリンク メールソフトが起動します。
マウスの右ボタンをクリックするとポップアップメニューが表示され、リンク先を同じウインドウに表示するか、別のウインドウを起動して表示するかを選択できます。

12-10. プロパティの表示

ポップアップメニューの[表示ページプロパティ]/[文書プロパティ]を選択するとプロパティが表示されます。
表示ページプロパティでは、用紙サイズ(判型、幅、高さ)、作成元の文書(オリジナルデータ)の種別、解像度、カラーモード、圧縮/画質、色数、OCR(文字認識)結果の有無を表示します。(カラーモードは[オリジナル種別]が[アプリケーション文書]の場合にだけ表示されます。また、圧縮/画質、色数、OCR結果の有無は、[イメージ文書]の場合にだけ表示されます。)
文書プロパティでは、ファイル名、種類、場所、サイズ、最終更新日、枚数を表示します。そのほかにDocuWorksバインダーの場合は、内部文書数、DocuWorksバインダーの色とサイズを表示します。セキュリティーが設定されている場合は、禁止されている操作、追加情報を表示します。隠し印刷設定がされている場合は、付加情報を表示します。

12-11. 印刷

標準ツールバー/ポップアップメニューで、表示している文書を印刷します。
印刷が禁止されている保護文書の場合は、印刷はできません。
アノテーションなどの透過色部分が正しく印刷されないプリンター(ESC/Pageプリンター)の場合は、[印刷]ダイアログボックスの[透過色部分を斜線に置き換えて印刷]にチェックマークを付けて、印刷してください。
[印刷用紙の大きさにあわせて拡大/縮小]にチェックマークを付けると、指定した印刷用紙のサイズに合わせて拡大/縮小して印刷します。各ページのサイズが異なる文書を、同じサイズの用紙に印刷できます。
[印刷可能な領域に縮小する]にチェックマークを付けると、プリンターの印刷可能領域に収まるように縮小して印刷します。さらに[付箋も含める]にチェックマークを付けると、はみ出した付箋も印字可能領域に収まるように縮小して、印刷します。
[ページサイズにあわせて印刷用紙を自動選択]にチェックマークを付けると、ページを等倍で印刷できる用紙を自動的に選択して印刷します。

12-12. 複製を保存

標準ツールバー/ポップアップメニューで、表示したDocuWorksファイルを別のファイルに保存できます。
ただし、回転の結果は保存されません。

12-13. 文字列の検索

ウインドウに表示したDocuWorksファイルの、文字列を検索できます。

12-13-1. 検索の実行

  1. 標準ツールバーまたはポップアップメニューの[検索]を選択します。
    [検索]ダイアログボックスが表示されます。
  2. 検索する文字列、検索条件を設定して、[次を検索]をクリックします。
    検索が始まり、検索された文字列が選択状態になります。
  3. 検索を続ける場合は、標準ツールバー/ポップアップメニューの[前を検索](キーボードの場合は<Shift>+<F3>キー)、または[次を検索](キーボードの場合は<F3>キー)をクリックします。
    • 複数ページにわたる文字列は検索対象になりません。
    • 見出し・ページ番号の設定で付けた見出し・ページ番号は、検索の対象になりません。
    • アノテーション非表示のときに検索すると、「一致するテキストアノテーションが見つかりませんでしたが、アノテーション非表示状態なので選択表示できません。」とのメッセージが表示されます。検索するテキストアノテーションが貼り付けてあるページは表示されますが、テキストアノテーションは選択されません。

12-13-2. [検索]ダイアログボックス

次の項目で、検索条件を設定します。
文字列
検索文字列を指定します。半角英数の場合で、区切りのスペースも含めて255文字以内で入力してください。改行およびタブは入力できません。
スペースも検索文字列として検索できます。
「A B」のように全角/半角スペースで区切って「AまたはB」という検索条件を設定できます。スペースを検索文字列にしたい場合は、スペースを半角の「""(ダブルクォーテーション)」で囲んで入力します。
半角のダブルクォーテーション、半角の円記号「¥」、または半角/全角スペースを文字列に含めるときは、その文字の直前に半角の円記号「¥」を入力します。
対象
アプリケーションから作成されたページのテキスト、OCR(文字認識)をしたイメージのページのテキスト、およびテキストアノテーションを、検索対象にするかしないかをそれぞれ設定します。チェックマークを付けると、検索の対象になります。初期値は、チェックマークが付いています。
区別しない文字の種類
大文字/小文字、全角/半角、ひらがな/カタカナを区別するかしないかをそれぞれ設定します。チェックマークを付けた場合、区別しないで検索します。初期値は、チェックマークが付いています。

12-14. 本文テキストの選択とコピー

標準ツールバー/ポップアップメニューの[テキスト選択モード]を選択すると、カーソルが「+A」の形になります。ページの上でドラッグしてテキストを選択できます。アプリケーションページのテキストは文字単位で、イメージページのOCR(文字認識)結果のテキストは行単位またはページ単位で選択されます。
本文テキストを選択してポップアップメニューの[選択文字列のコピー]を選択すると、選択した文字列がクリップボードにコピーされ、ほかのアプリケーションファイルなどに貼り付けることができます。 <F4>キーを押すと、スクロールモードとテキスト選択モードが交互に切り替わります。
  • ページをまたがる選択はできません。
  • ポップアップメニューの[すべてを選択]を選択すると、表示ページの選択可能なテキストがすべて選択されます。
  • 本文テキストを選択して、ポップアップメニューの[Webブラウザーを起動]を選択すると、選択文字列をURLとしてWebブラウザーが起動します。テキストアノテーションを選択するか、または何も選択しないでポップアップメニューの[Webブラウザーを起動]を選択すると、アドレスは空欄でWebブラウザーが起動します。
  • 転記が禁止されている保護文書の場合は、テキストのコピーはできません。

12-15. 部分イメージコピー

標準ツールバー/ポップアップメニューの[部分イメージコピー]を選択すると、カーソルの形が変わります。マウスの左ボタンでページの一部をクリックし、そのままドラッグすると四角形が描画され、範囲を指定できます。左ボタンを離すと、選択した範囲がクリップボードにビットマップデータとしてコピーされ、ほかのアプリケーションファイルなどに貼り付けることができます。
部分イメージコピーの解像度と、カラーモード([カラー]/[白黒])は、ポップアップメニューの[DocuWorks Viewer Light Controlの設定]を選択して表示されるダイアログボックスで設定できます。
[解像度]に指定できる範囲は、75~600dpiです。
転記が禁止されている保護文書の場合は、部分イメージコピーはできません。

12-16. OCR結果の表示

ポップアップメニューで、DocuWorks DeskまたはDocuWorks Viewerで実行したOCR(文字認識)結果を表示します。
[OCR結果の表示]ダイアログボックスが表示され、OCR結果の選択とコピーができます。表示ページにOCR結果がない場合は、このメニューは選択できません。
転記が禁止されている保護文書の場合は、OCR結果のコピーはできません。

12-17. オリジナルデータまたは内容物の取り出し

標準ツールバー/ポップアップメニューで、表示したDocuWorksファイルに添付されているオリジナルデータ、またはDocuWorks入れ物の内容物を取り出せます。
  1. 標準ツールバーまたはポップアップメニューの[オリジナルデータ/内容物の取り出し]を選択します。
    [オリジナルデータ/内容の取り出し]ダイアログボックスが表示されます。
  2. 取り出すファイルを選択して、[取出し]をクリックします。
    [オリジナルデータの保存]ダイアログボックスが表示されます。
    バイトサービング機能を使って部分的にダウンロードしている場合に、オリジナルデータがダウンロードされていないときは、ダウンロードが始まります。ダウンロードが終了すると、[オリジナルデータの保存]ダイアログボックスが表示されます。
  3. 保存する場所とファイル名を設定して[複製を保存]をクリックします。
    オリジナルデータまたは内容物が取り出されます。
  • 転記が禁止されている保護文書の場合は、オリジナルデータまたは内容物の取り出しはできません。

12-18. セキュリティーの操作

パスワードによる保護文書を表示するには、開くパスワードが必要です。
DocuWorks電子印鑑や電子証明書による保護文書は、DocuWorks Viewer Light for Webでは開けません。
ただし、DocuWorks 6以降がインストールされていて、その保護文書を開くために必要な電子印鑑が用意されている場合は開けます。電子証明書による保護文書の場合は、DocuWorks 6以降がインストールされていて、セキュリティーの設定に使われた証明書が、Windows® Internet Explorer®の[証明書マネージャ]の[個人]タブに登録されている場合に開けます。
DocuWorks Viewer Light for Webでは、「印刷」、「オリジナルデータの取り出し」、「アノテーションの表示/非表示」、「回転」、「テキストコピー」、「OCR結果の確認」、「部分イメージコピーモード」の操作が制限されます。権利のない操作に関連するメニュー、ツールボタンは、選択できなくなります。
機能と、実行するために必要な権利は次のとおりです。
機能必要な権利
印刷印刷権
オリジナルデータの取り出し転記権
アノテーションの表示/非表示 アノテーション編集権
回転 文書編集権
テキストのコピー 転記権
OCR結果テキストのコピー 転記権
部分イメージコピー 転記権

12-19. 署名文書の操作

  • 署名文書を表示できます。
  • 署名検証状態を表示できます。
  • 電子印鑑で署名された文書はDocuWorks本体がインストールされていないと署名の検証はできません。(14887)

12-20. バイトサービング機能について

WebサイトにあるDocuWorksファイルのページ数が多い場合、ファイル全体をダウンロードすると、表示に時間がかかることがあります。バイトサービング機能を使うと、表示するファイルのサイズが指定したサイズ以上の場合に、表示に必要な部分だけをダウンロードして表示時間を短縮できます。

12-20-1. バイトサービングに対応する操作

バイトサービングをするように設定すると、「DocuWorksファイルの表示」、「ページめくり」、「リンク先の表示」、「印刷」、「複製を保存」、「テキストの検索」、「オリジナルデータ取り出し」時に、バイトサービング機能を使って部分的にダウンロードされます。

12-20-2. バイトサービングが動作する条件

  • 表示するファイルのバージョンが、Ver. 2以上であることが必要です。
  • Webサーバーが、バイトサービングに対応していること、またバイトサービングを行うように設定していることが必要です。
    次のWebサーバーで、動作を確認しています。
    • Apache 2.0.x
    • Microsoft® Internet Information Services 6.0
    • Microsoft® Internet Information Services 7.0
    • Microsoft® Internet Information Services 8.0
  • ブラウザーが、バイトサービングに対応している必要があります。
    次のブラウザーで、動作を確認しています。
    • Windows® Internet Explorer® 11
  • Webサーバー上で動作する、CGIなどを利用したシステム上のDocuWorksファイルを表示する場合、そのシステムがバイトサービングに対応し、DocuWorksファイルへのURLを返す動作をする必要があります。

12-20-3. DocuWorks Viewer Light for Webのバイトサービングの設定

ポップアップメニューから、[DocuWorks Viewer Light Controlの設定]を選択し、表示されたダイアログボックスの通信タブで設定します。
設定内容は、次にDocuWorks Viewer Light for WebでDocuWorksファイルを表示したときから有効になります。
通信に関する設定
ダウンロードの方法を設定します。初期値は、[部分的にダウンロード]です。
すべてのデータをダウンロード
DocuWorksファイル全体をダウンロードしてから表示します。
部分的にダウンロード
表示するDocuWorksファイルのサイズが指定したサイズ以上の場合に、バイトサービング機能を使って表示に必要な部分だけをダウンロードします。ページめくりなどで、まだダウンロードしていない残りのページを表示するときは、表示に必要な部分を再度ダウンロードします。
指定できる範囲は、1~99,999KBです。初期値は、100KBです。
一時ファイルに関する設定
[部分的にダウンロード]を選択した場合に設定します。
バイトサービング機能を使ってDocuWorksファイルを部分的にダウンロードすると、ダウンロードしたページのコピーが保存されます。そのコピーを一時ファイルといいます。次に同じページを表示するときに、Webサイトにある実ファイルが更新されていない場合は、保存しておいた一時ファイルを表示して表示時間を短縮します。
この一時ファイルは、ブラウザーのキャッシュ機能とは異なります。ただし[すべてのデータをダウンロード]を選択した場合は、この一時ファイルは作成されず、ブラウザーのキャッシュ機能の設定に従います。
最大サイズ
一時ファイルのサイズを合計した最大値を設定します。最大サイズを超えると、作成日の古いファイルから削除されます。
指定できる範囲は、1~99MBです。初期値は、50MBです。
一時ファイルの場所
一時ファイルを置く場所を設定します。初期値は「環境変数TEMPで指定したディレクトリー¥Cache」です。
一時ファイルを削除
一時ファイルをすべて削除します。表示中のファイルは、DocuWorks Viewer Light for Webの終了時に削除されます。

12-21. ActiveX®コントロール対応について

DocuWorks Viewer Light for Webは、ActiveX®コントロールに対応しているので、ActiveX®コントロールコンテナでDocuWorksファイルを閲覧、印刷できます。
DocuWorks Viewer Light for Webのコントロール名は、[DocuWorks Viewer Light Control]です。
詳細は『DocuWorks Development Tool Kit 8 DocuWorks Viewer Control/DocuWorks Viewer Light Controlインターフェイス仕様書』を参照してください。

12-22. DocuWorksファイルを表示する場合のURLやHTMLの指定について

HTML内にDocuWorksファイルを埋め込んで表示する場合、次のタグで指定してください。
<EMBED 属性名="値"><⁄EMBED>
属性名とその値は、次のとおりです。
属性名内容
SRC表示するDocuWorksファイル名
WIDTH表示するDocuWorksファイルの横サイズ(ピクセル数)(省略時はブラウザーに依存)
HEIGHT表示するDocuWorksファイルの縦サイズ(ピクセル数)(省略時はブラウザーに依存)
PAGE表示するDocuWorksファイルのページ(省略時は1)
SHEAFDocuWorksバインダー内の文書の名前(省略時はなし)
例:<EMBED SRC="sample.xdw" WIDTH="300"><⁄EMBED>
HTML内にA4縦のDocuWorksファイルを埋め込む場合、HEIGHTは90~3518、WIDTHは65~2488の範囲を設定すると正しく表示されます。
WIDTH、HEIGHTに%値を指定できる場合、DocuWorksファイルの大きさは、表示ではウインドウサイズ、印刷では用紙サイズの相対で決まります。

12-23. サーバー管理者のかたへ(Webサーバーの設定について)


12-23-1. 新規にDocuWorksファイルをWebで公開するサーバー管理者のかたへ

DocuWorks Viewer Light for Webで設定しているMIMEタイプと拡張子は、次のとおりです。お使いのWebサーバーによっては、あらかじめ設定されているものもありますが、以下のエントリーがない場合、この値を設定してください。
MIMEタイプ
application/vnd.fujixerox.docuworks
拡張子
xdw
MIMEタイプ
application/vnd.fujixerox.docuworks.binder
拡張子
xbd
MIMEタイプ
application/vnd.fujixerox.docuworks.container
拡張子
xct

12-23-2. すでにDocuWorksファイルをWebで公開しているサーバー管理者のかたへ

WebサーバーのMIMEタイプを、application/x-fx-xdwで設定している場合、上記MIMEタイプの設定へ変更してください。

13. 注意と制限

DocuWorks Viewer LightおよびDocuWorks Viewer Light for Webの操作上の注意事項、制限事項について説明します。
本書で説明しているシステムエラーとは、ウインドウがアプリケーションエラーや一般保護違反などで閉じたり、Microsoft® Windows®が強制終了するような状態をいいます。

13-1. 操作


13-1-1. DocuWorks Viewer Light

アプリケーションによっては、表示上の文字の並びと異なる順序で印刷処理を行うものがあります。このようなアプリケーションから変換されたDocuWorks文書内部のテキスト情報は、表示上の文字の並びと異なる順序で保持しているため、テキスト検索の結果が、表示どおりの順序とならないことがあります。(5572)

13-1-2. DocuWorks Viewer Light for Web

  • DocuWorks Viewer Light for Webでリンクアノテーションを利用する場合、[DocuWorksファイルの設定]ダイアログボックスの[ファイル名]にローカルパスやUNCパスを設定しているとき、ブラウザーの種類によっては、正常にファイルを表示できなかったり、ページ指定やバインダーの内部文書指定が無効になったりすることがあります。(4167、11545、13658)
  • アプリケーションによっては、表示上の文字の並びと異なる順序で印刷処理を行うものがあります。このようなアプリケーションから変換されたDocuWorks文書内部のテキスト情報は、表示上の文字の並びと異なる順序で保持されているため、テキスト検索の結果が、表示どおりの順序とならないことがあります。(5572)
  • 日本語のファイル名がエンコードされている場合、そのファイルを[複製を保存]または[印刷]すると、エンコードされたファイル名のまま保存または印刷されます。(5608)
  • アプリケーションやフォントの指定によっては、文字をイメージとして印刷処理を行うことがあります。このような場合、変換されたDocuWorks文書は、テキスト情報を保持していないので、テキスト検索の対象になりません。(6537)
  • WebサーバーにあるDocuWorksファイルをクライアントからDocuWorks Viewer Light for Webで表示すると、バイトサービング機能が動作しない場合があります。これは、DocuWorks Viewer Light for Webがヘッダー情報にクライアントの現在時刻を付加してWebサーバーと通信をしているためです。Webサーバー側の時刻設定をクライアント側よりも遅らせると、この問題を回避できます。(7233)
  • 署名上に透過なアノテーションが重なっている場合、重なっている部分では署名の検証などの操作はできません。(11172)
  • DocuWorks 6.x以上がインストールされていない場合は、Windows® Internet Explorer®で、DocuWorks電子印鑑の署名を検証できません。(13553)

13-2. 表示/印刷結果


13-2-1. DocuWorks Viewer Light

  • アプリケーションによっては、色の違いが画面表示より印刷したときの方が見分けにくくなるものがあります。そのため、その文書をDocuWorksファイルに変換した場合、元の文書とくらべて、色の表示が異なることがあります。(46)
  • アプリケーションにより、DocuWorksファイルに変換するとパターンが塗りつぶされて表示されるものがあります。ただし、DocuWorksファイルを印刷する場合は問題ありません。(51)
  • アプリケーションにより、塗りつぶしが正しく表示されないことがあります。ただし、DocuWorksファイルを印刷する場合は問題ありません。(65)
  • ハッチパターンがあるファイルは、アプリケーションで表示した場合と、DocuWorksファイルに変換してDocuWorks Viewerで表示した場合とで、画面との表示が異なることがあります。ただし、プリンターに印刷した場合は、両者に違いはありません。(174)
  • 画面の色数を256色以下に設定しているディスプレイでは、文書中の色は、ディザで表現されます。ただし、プリンターに印刷した場合は、両者に違いはありません。(174)
  • 株式会社ジャストシステム®の一太郎®で作成したファイルのうち、図形にさまざまな塗りつぶし(パターン)を設定したものをDocuWorksファイルに変換すると、DocuWorks Viewerで表示した場合、パターンが表示されなかったり、真っ黒に表示されるなどして、アプリケーションで表示した場合と異なることがあります。アプリケーションでは、塗りつぶし(パターン)が表示と印刷の解像度の違いに対応するために、表示における独自の工夫をしています。したがって、アプリケーションの表示とDocuWorksファイルに変換したものの表示が異なってしまいます。ただし、アプリケーションで作成されたファイルを直接プリンターに印刷した結果と、DocuWorksファイルをプリンターに印刷した結果は同じになります。(621)
  • 株式会社ジャストシステム®の一太郎®8上で、中抜きの属性を設定した文字があるファイルをDocuWorksファイルに変換すると、DocuWorks Viewer Light上で、文字がつぶれて表示されないことがあります。この場合は倍率を上げて表示すると、見えるようになります。文字がつぶれる現象は、欧文フォントよりも日本語フォントが使われている場合の方がより多く見られます。プリンターに出力した場合は、問題ありません。(633)
  • 富士通株式会社のOASYS®で作成された文書で、図形にさまざまな色のシェードを設定してDocuWorksファイルに変換した場合、DocuWorks Viewerで表示したときに、べた塗りで表示されることがあります。表示倍率を上げていくと、薄いシェードで表示されるようになります。アプリケーションでは、シェードを表示と印刷の解像度の違いに対応させるために、表示における独自の工夫をしています。そのため、アプリケーションの表示とDocuWorksファイルに変換した場合の表示が異なります。ただし、アプリケーションで作成されたファイルを直接プリンターに出力した結果と、DocuWorksファイルをプリンターに印刷した結果は同じになります。(661)
  • 株式会社ジャストシステム®の一太郎®で作成された文書で、図形にさまざまな色のシェードを設定しているものをDocuWorksファイルに変換した場合、DocuWorks Viewerで表示したときに、べた塗りで表示されることがあります。表示倍率を上げていくと、薄いシェードで表示されるようになります。アプリケーションでは、シェードを表示と印刷における解像度の違いに対応させるために、表示における独自の工夫をしています。そのため、アプリケーションの表示とDocuWorksファイルに変換した場合の表示が異なります。ただし、アプリケーションで作成されたファイルを直接プリンターに印刷した結果と、DocuWorksファイルをプリンターに印刷した結果は一致します。(665)
  • アプリケーションで作成されたファイルがビットマップやカラーパターンなどを含んでいる場合、DocuWorksファイルに変換したものをDocuWorks Viewer Lightで表示すると、表示されるまでに時間がかかることがあります。(670)
  • アドビ システムズ社のAdobe® PageMaker® 6.0で作成されたファイルで、傍点の属性を設定した文字があるファイルをDocuWorksファイルに変換すると、DocuWorks Viewer上で、傍点の部分がAやBに文字化けして表示されることがあります。これは、Adobe® PageMaker®が傍点を特殊なフォントで出力しており、起動時に使用可能な状態に設定しているためです。Adobe® PageMaker®がインストールされていなかったり、インストールされていても、その変換文書を表示するまでにAdobe® PageMaker®を一度も起動していなかった場合に発生します。(680)
  • ファイル名に半角文字の「&」が含まれているDocuWorksファイルを印刷した場合は、印刷時に表示されるダイアログボックス内のファイル名に「&」が表示されません。また、「&」の次の文字に下線が表示されます。(904)
  • アドビ システムズ社のAcrobat®から作成したDocuWorksファイルを表示したとき、欧文フォントの一部と記号系フォントが文字化けすることがあります。(1270)
  • DocuWorks Ver. 2.0で作成したDocuWorks文書のマーカーアノテーション(透過なフリーハンド)は、PostScript®プリンターに印刷した場合や[印刷]ダイアログボックスの[透過色部分を斜線に置き換えて印刷]にチェックを付けて印刷しても、斜線で印刷されません。(1464)
  • テキストアノテーションの大きさが一定サイズを超える場合は、文字部分が斜線で表示されます。(1529)
  • Freelanceから作成したDocuWorksファイルをPCL5プリンター(HP社製)に印刷すると、文字に設定された下線や取り消し線が印刷されず、白抜けになってしまうことがあります。(1904)
  • アプリケーションから作成された横長のDocuWorksファイルをPostScript®プリンターに印刷する場合、パターン(例えば縦線、横線、斜線のハッチパターンなど)で塗りつぶされた部分が90度回転して印刷される場合があります。(1908)
  • 富士通株式会社のOASYS®から作成したDocuWorksファイルをPCL5プリンター(HP社製)に印刷すると、横書きの文字が斜めにずれて印刷されることがあります。(2017)
  • DocuWorksファイルをPCL5プリンター(HP社製)に印刷すると、行の一番最初の文字が行の途中や末尾に移動して印刷されることがあります。(2019)
  • 株式会社ジャストシステム®の一太郎®から作成したDocuWorksファイルを、PCL5プリンター(HP社製)に印刷すると、グラフのパターンや図形の塗りつぶしなどが一部白く抜け、位置がずれて印刷されることがあります。(2024)
  • Lotus ® 1-2-3から作成したDocuWorksファイルをPCL5プリンター(HP社製)に印刷すると、グラフの背景のパターンが一部が乱れることがあります。(2039)
  • 株式会社ジャストシステム®の一太郎®から作成したDocuWorksファイルをNPDLプリンター(NEC社製)に印刷すると、図形の塗りつぶしパターンが乱れて印刷されることがあります。(2040)
  • 1ポイントのフリーハンドアノテーションがあるDocuWorksファイルをPCL5プリンター(HP社製)に印刷すると、一部が点線で印刷されることがあります。(2078)
  • [印刷]ダイアログボックスで[透過色部分を斜線に置き換えて印刷]をチェックして印刷した場合、透過色部分を斜線に置き換えますが、その斜線がパターンと色の干渉によって斑になることがあります。(2149)
  • GDIプリンター、ESC/Pageプリンター、PostScript®プリンターにシェードやパターンで塗りつぶされたグラフィックを含むDocuWorksファイルを印刷すると、アプリケーションから直接印刷した場合と印刷結果が異なることがあります。(1861、2247)
  • 使用しているディスプレイカードによっては、特定の表示倍率で、本文テキストの右端が欠けて表示されることがあります。この場合は、ディスプレイカードのパフォーマンスの設定を変更してください。(6992)
  • Microsoft® Windows® 98 Second Edition、Windows® Millennium Edition(Windows® Me)で、Microsoft® PowerPoint®文書などから作成したDocuWorks文書を表示/印刷すると、テクスチャーやシェードが元の文書とは異なったパターンで表示/印刷されることがあります。(7538)
  • ロータススーパーオフィス®文書から作成したDocuWorks文書を印刷すると、グラデーションに白い線が入ることがあります。(7601)
  • 画像を回転して貼り付けたQuarkXPress®文書から作成したDocuWorks文書を表示すると、画像に白い線が入ることがあります。(7618)
  • 画像を回転して貼り付けたQuarkXPress®文書から作成したDocuWorks文書を表示/印刷すると、画像の一部に細かい黒点が表示/印刷されることがあります。(7622)
  • Microsoft® Officeで作成された文書の透過設定にした画像や図形は、DocuWorks文書にした場合、表示すると、べた塗りまたは白抜けになることがあります。この場合、DocuWorks文書に変換するときに解像度を落として変換してください。(11122)
  • グラデーションや透過の画像を、[ビットマップや図形データに変換した文字の縁をなめらかに表示する]に設定して表示すると、画像にはない線が表示されたり、変色したりすることがあります。(11139)
  • アプリケーションの印刷時の描画方法によっては、変換したDocuWorks文書を表示するときに、画像、記号などが部分的に白抜けしたり、線が入ったりすることがあります。(11125、14044)
  • 東アジア圏の日本語以外のMicrosoft® Windows®で作成されたDocuWorksファイルを、日本語版のMicrosoft® Windows®で表示すると、フォント置換が行われ、別のフォントに設定されることがあります。(11413)
  • 点線(丸)を使用したMicrosoft® PowerPoint®文書から作成したDocuWorks文書をDocuWorks Viewer Lightで表示すると、表示されるまでに時間がかかることがあります。その場合は、[DocuWorks Viewer Lightの設定]ダイアログボックスの[表示]タブから、[ビットマップや図形データに変換した文字の縁をなめらかにする]のチェックを外してください。(12001)
  • DocuWorks 7以降で作成した直線アノテーションをDocuWorks 6以前で表示した場合、表示倍率によってはかすれることがあります。表示倍率を上げると表示されます。(15149)
  • テキスト検索を行う場合、次の条件は検索の対象になりません。
    • 複数ページにわたる文字列
    • Viewerで設定した見出しやページ番号
    • OCR処理がされていないイメージ文書
    • 文書情報が入っていないアプリケーションページ
    • 文字が図形になっているアプリケーションページ
    • 検索したいテキストが文中で改行されている場合
    • OCR処理が誤認識されている文書
    • 表示上の文字の並びと異なる順序で、印刷処理が行われた文書

13-2-2. DocuWorks Viewer Light for Web

  • 埋め込み表示からブラウザー全体で表示に切り替えた場合、100%の倍率で表示します。また、アノテーションも常に表示状態となります。(2216)
  • HTML内にDocuWorksファイルを埋め込んで表示する場合、次のような条件のとき、埋め込まれている箇所に「×」が表示、印刷されることがあります。この場合、WIDTHとHEIGHTの値を小さくしてください。
    • WIDTHとHEIGHTの値によってDocuWorksファイルを10%以下または1600%以上で表示、印刷するとき(2321)
  • 回転したDocuWorks文書をMicrosoft® Excel® 2000で表示して印刷した場合、Microsoft® Excel® 2000の制限により、文字列の部分が回転しないで印刷されます。(5744)
  • 使用しているディスプレイカードによっては、特定の表示倍率で、本文テキストの右端が欠けて表示されることがあります。この場合は、ディスプレイカードのパフォーマンスの設定を変更してください。(6992)
  • ロータススーパーオフィス®文書から作成したDocuWorks文書を印刷すると、グラデーションに白い線が入ることがあります。(7601)
  • 画像を回転して貼り付けたQuarkXPress®文書から作成したDocuWorks文書を表示すると、画像に白い線が入ることがあります。(7618)
  • 画像を回転して貼り付けたQuarkXPress®文書から作成したDocuWorks文書を表示/印刷すると、画像の一部に細かい黒点が表示/印刷されることがあります。(7622)
  • 点線(丸)を使用したMicrosoft® PowerPoint®文書から作成したDocuWorks文書をDocuWorks Viewer Light for Webで表示すると、表示されるまでに時間がかかることがあります。その場合は、[DocuWorks Viewer Light Controlの設定]、または[DocuWorks Viewer Light for Webの設定]ダイアログボックスの[表示]タブから、[ビットマップや図形データに変換した文字の縁をなめらかにする]のチェックを外してください。(12001)
  • 次の場合、FTPサーバーにあるDocuWorksファイルは表示できないことがあります。(13037、13396)
    • ファイル名に2バイトの文字が含まれている場合
    • Proxyサーバーを経由して表示した場合
  • フォームデータを送信してDocuWorks文書を表示するようなWebアプリケーションにおいて、DocuWorks文書を一度表示したあとにブラウザーの更新(再読み込み)を実行した場合、正常に表示されません。(13990)
  • sheaf属性を使って内部文書のページを表示させる場合や、linktitle属性を使ってリンクアノテーションの付いたページを表示させる場合、属性の値として次の文字が含まれていると、属性の指定が有効になりません。(14052)
    • 半角スペース
    • &
    • #
  • DocuWorks 7以降で作成した直線アノテーションをDocuWorks 6以前で表示した場合、表示倍率によってはかすれることがあります。表示倍率を上げると表示されます。(15149)
  • テキスト検索を行う場合、次の条件は検索の対象になりません。
    • 複数ページにわたる文字列
    • Viewerで設定した見出しやページ番号
    • OCR処理がされていないイメージ文書
    • 文書情報が入っていないアプリケーションページ
    • 文字が図形になっているアプリケーションページ
    • 検索したいテキストが文中で改行されている場合
    • OCR処理が誤認識されている文書
    • 表示上の文字の並びと異なる順序で、印刷処理が行われた文書

13-3. 印刷/ドライバーの設定


13-3-1. DocuWorks Viewer Light

  • アプリケーションで作成されたファイルをDocuWorksファイルに変換するときの解像度と、そのDocuWorksファイルをプリンターへ印刷するときの解像度が異なる場合、作成されたアプリケーションからプリンターへ印刷した場合と印刷結果が異なることがあります。DocuWorksファイルへ変換するときの解像度とDocuWorksファイルをプリンターに印刷するときの解像度を合わせてください。(623)
  • DocuWorksファイルを、スプールデータ形式が[EMF]に設定してあるESC/Pageプリンター(EPSON社製)に印刷すると、印刷終了後にWindows®システムが動作しなくなることがあります。その場合、スプールデータ形式を[RAW]にするか、スプールしないように設定してください。(1881)
  • 株式会社ジャストシステム®の一太郎®でシェードのかかった表項目を含む文書を、DocuWorksファイルに変換して印刷すると、表内のシェードの色が変わったりシェードの長さが短くなることがあります。この場合、プリンターの画質に関する設定を変更することによって、現象を回避できることがあります。(1998)
  • サイズの大きいビットマップから作成したDocuWorksファイルは、プリンタードライバーによって正しく印刷できないことがあります。例えば、A2-400dpi相当(4,960x7,015dot)、A3-600dpi相当(7,015x9,921dot)のモノクロビットマップからDocuWorksファイルを作成して、PostScript®プリンターに印刷した場合などです。この場合、プリンタードライバーの解像度指定を下げてください。(2182)
  • Microsoft EdgeやストアアプリからDocuWorks Printerへ印刷すると、文字が図形データに変換されてDocuWorks文書に出力されます。この場合、DocuWorks文書上でテキスト選択できなくなり、DocuWorks文書のドキュメントサイズが大きくなることがあります。(24246)

13-3-2. DocuWorks Viewer Light for Web

  • 隠し印刷を設定したDocuWorksファイルを印刷するには、次の条件が必要です。
    TrustMarkingBasic Ver.2.2以上がインストールされているPCであること。
    TrustMarkingBasicに対応しているプリンターに出力すること。(10906)

13-4. メモリー/パフォーマンス


13-4-1. DocuWorks Viewer Light

  • メモリーが不足している場合は、DocuWorksファイルのページのイメージが表示されない(ページに「×」が書かれる)ことがあります。表示倍率を小さくするか、または他のアプリケーションを終了して、DocuWorks Viewer Lightを再起動してください。(21)
  • 一部複雑な文書表現(パターン模様による塗りつぶし、グラデーション表現、ビットマップ描画の多用など)を含むデータから作成したDocuWorksファイルを、PostScript®プリンターに印刷すると、PostScript®データサイズが大きくなります。このため、オリジナルのデータより印刷に時間がかかったり、プリンターの容量をオーバーすることがあります。(2030)

13-4-2. DocuWorks Viewer Light for Web

  • 1ページあたりに埋め込み表示できるDocuWorksファイルの数は、使用しているクライアントのメモリーやディスク容量に依存します。多くのDocuWorksファイルが埋め込まれたページを閲覧する際には、リソースに注意してください。(2290)
  • PCに確保できるメモリー領域の大きさによっては、ファイルサイズが数百MB以上の文書上の電子署名の検証が失敗することがあります。(12535)

13-5. DocuWorks Viewer Light(文書情報持ち出し操作制限版)について

DocuWorks Viewer Light (文書情報持ち出し操作制限版) には、起動時に連携ソフトウェアの処理を呼び出す機能があります。連携ソフトウェアの処理を呼び出せなかったときは、「DLLの初期化に失敗しました。」というメッセージを表示して起動を中止します。その他の起動時に表示されるメッセージで、ウインドウのタイトルが「DocuWorks Viewer Light」以外のものについては、それぞれの連携ソフトウェアのマニュアルなどをごらんください。

13-6. DocuWorks Viewer Light for Webのバイトサービング

  • WebサーバーがNetscape Enterprise Serverで、クライアントがWindows® Internet Explorer® 11の環境ではクライアントでバイトサービングが有効になるように設定していても、すべてのページが一度にダウンロードされます。(5751)
  • バイトサービング機能を利用する設定の場合で、WebサーバーにあるDocuWorksファイルを表示するとき、経由するプロキシの動作によっては、エラーメッセージの「指定ファイルはDocuWorks文書のファイルではありません。」が表示され、DocuWorksファイルを表示できないことがあります。この場合、バイトサービング機能を利用しない設定に変更してご利用ください。(13754)

14. DocuWorks Content Filter 8について

DocuWorks Content Filter 8は、Microsoft® Windows®インデックスサービス、およびMicrosoft® Windows® 7、Microsoft® Windows® 8.1、Microsoft® Windows® 10のWindows® Search Serviceのインターフェイス(IFilter)に準拠したコンテンツフィルターです。
このフィルターは、文書検索ソフトウェアによって、検索用のインデックスを作成するときに呼び出され、文書検索ソフトウェアが必要とする全文テキスト情報、および文書属性を、DocuWorksファイルから抽出する機能を持っています。
DocuWorks Viewer Light 8をインストールすると、同時にDocuWorks Content Filter 8もインストールされます。Windows® インデックスサービス、Windows® Search Service、またはJustsystem® ConceptBase Search® 1000などの文書検索ソフトウェアによって、DocuWorksファイルが検索対象になります。

14-1. 対象になる文書検索ソフトウェア

対象になる文書検索ソフトウェアは、次の4つがあります。
  • Windows® インデックスサービス
  • Windows® Search Service
  • Justsystem® ConceptBase® Search 1000 Ver.4.0/4.1/4.2
  • Justsystem® ConceptBase® IV/V

14-2. 抽出対象と方法


14-2-1. 対象になるDocuWorksファイル

  • DocuWorks文書
  • DocuWorksバインダー
  • DocuWorks入れ物
DocuWorks Content Filterは、DocuWorks 8とそれ以前のDocuWorksファイルに対応しています。
保護文書は、以下の場合に対象になります。すべての場合で、転記権が必要です。
  • パスワードで保護された文書のうち、開くパスワードが設定されていないDocuWorksファイル
  • パスワードで保護された文書のうち、開くパスワードが一時記憶されているDocuWorksファイル
  • 電子印鑑により保護されている文書のうち、印鑑ケースが開いており、対話操作なく文書が開けるDocuWorksファイル
  • コンテキストサービスにより保護された文書のうち、コンテキストサーバに認証ができるDocuWorksファイル

14-2-2. 抽出する対象

DocuWorks Content Filterは、DocuWorksファイルから次の内容や文書プロパティを抽出します。
抽出される項目 説明
内容 [Contents] ・本文テキスト
・OCR(文字認識)したテキスト
・テキストアノテーションのテキスト
(付箋上のテキストアノテーションのテキストを含む)
文書名 [DocTitle] [文書のプロパティ]で設定されたタイトル
サブタイトル(主題) [DocSubject] [文書のプロパティ]で設定されたサブタイトル
作成者 [DocAuthor] [文書のプロパティ]で設定された作成者
キーワード [DocKeywords] [文書のプロパティ]で設定されたキーワード
コメント [DocComments] [文書のプロパティ]で設定されたコメント
ユーザー定義属性 [文書のプロパティ]で設定されたユーザー定義
アプリケーション名 [DocAppName] アプリケーション名。常に[DocuWorks]になります。
※[ ]内は、Windows® インデックスサービス、およびWindows® Search Service(Windows® 7、Windows® 8.1、Windows® 10)のヘルプに記載されているプロパティ名です。ただし、ユーザー定義属性のプロパティ名は任意です。

14-2-3. 抽出方法

DocuWorks Content Filterは、DocuWorksファイルから次の方法でテキストを抽出します。
テキストを抽出する順番
「内容」は、本文テキスト(またはOCRしたテキスト)、テキストアノテーションの順に抽出します。1ページめから最後のページまで本文テキストを抽出したあとに、1ページめに戻ってテキストアノテーションを抽出します。
テキストの改行位置
本文テキスト(またはOCRしたテキスト)とテキストアノテーションの間と、テキストアノテーション同士の間に改行文字が挿入されます。
最後のテキストアノテーションの末尾にも、改行文字が挿入されます。

14-3. 注意と制限

Microsoft® Windows® 7、Microsoft® Windows® 8.1、またはMicrosoft® Windows® 10を使用している場合は、以下の「Window® インデックスサービス」を「Windows® Search Service」に読み換えてください。
  • DocuWorks Content Filterをインストールしたあとに、DocuWorks、またはDocuWorks関連のモジュールをアンインストールした場合のDocuWorks Content Filterの動作は保証しません。削除されたレジストリを登録するために、DocuWorks Content Filterを再度インストールしてください。
  • DocuWorks文書を開いたまま、Windows® インデックスサービスでインデックスの作成を行った場合、処理が完了しません。この場合、開いている文書を閉じると、処理が完了します。詳細については、Windows® インデックスサービス付属のオンラインリファレンスをごらんください。(3396)
  • 文字認識(OCR)処理されたテキスト情報を含むDocuWorks文書に対して、本コンテンツフィルターを使用する場合、抽出されたテキスト情報の精度は、文字認識処理の結果に依存しています。
  • DocuWorks Content Filterがインストールされている環境にDocuWorks、または、DocuWorks Viewer Lightがインストールされている場合、転記権があり一時的に開くパスワードが記憶されている保護文書は、検索対象になることがあります。
  • Windows® インデックスサービスにおいて、DocuWorksファイルに開くパスワードが設定されていることによりインデックス作成が行われなかった場合、Windows® インデックスサービス管理ツールの[非フィルター処理文書の表示]に何も表示されません。(5217)
  • アプリケーションによっては、表示上の文字の並びと異なる順序で印刷処理を行うものがあります。
    このようなアプリケーションから変換されたDocuWorks文書内部のテキスト情報は、表示上の文字の並びと異なる順序で保持しているため、DocuWorks Content Filterを使用したテキスト情報の取得結果が、表示どおりの順序とならないことがあります。(5572)
  • アプリケーションやフォントの指定によっては、文字をイメージとして印刷処理を行うことがあります。このような場合、変換されたDocuWorks文書は、テキスト情報を保持していないので、テキスト検索の対象になりません。(6537)
  • 文書に含まれる文字数が多い(例:100万文字以上)ファイルは、検索用データをシステムに登録できません。このため、インデックスサービス検索の対象にならないことがあります。(13243)
  • 中国語版のDocuWorks 5.xを使用してOCR処理されたページは、インデックスサービスによる検索ができません。

14-4. Justsystem® ConceptBase Search® 1000でDocuWorksファイルを検索するときの注意事項

Justsystem® ConceptBase Search® 1000を使ってDocuWorksファイルを検索するときの注意事項を説明します。詳細については、Justsystem® ConceptBase Search® 1000のマニュアルをごらんください。

14-4-1. Justsystem® ConceptBase Search® 1000 Microsoft® Windows®クライアントをご利用の場合

Justsystem® ConceptBase Search® 1000 Microsoft® Windows®クライアントをご利用の場合、各クライアントの環境に次のソフトウェアがインストールされている必要があります。
  • Justsystem® ConceptBase Search® 1000 Ver.1.33以降
  • DocuWorks Content Filter 7.3以降

14-4-2. Justsystem® ConceptBase Search® 1000 Webクライアントをご利用の場合

Justsystem® ConceptBase Search® 1000でDocuWorksファイルを検索対象にする場合、Webクライアントの検索結果において、DocuWorksファイルの見出しが非常に長く表示されることがあります。
見出しの文字数を制限する場合は、以下の設定を行い、文書データベースを再作成する必要があります。
  • Justsystem® ConceptBase Search® 1000 Ver.3.0の場合
    [CBSearchサーバーマネージャー]でDocuWorks文書が登録されている文書データベースを選択して、[詳細]タブの[属性変更]をクリックします。
    [文書データベース属性変更ダイアログ]の[詳細]をクリックして、[タイトル抽出設定]で[最大文字数]を変更してください。
    推奨値は40文字です。

15. 情報入手先

富士ゼロックスのホームページで、最新の情報を入手できます。
次のURLにアクセスしてください。
http://www.fujixerox.co.jp/product/software/docuworks/

16. その他

本ソフトウェアおよびバックアップのために複製されたソフトウェアに関する著作権等を含む一切の無体財産権は、弊社および弊社への供給者に帰属します。
Microsoft、Windows、ActiveX、Visual Basic、Visual C++、Excel、Access、PowerPoint、およびInternet Explorerは、米国Microsoft Corporationの、米国およびその他の国における登録商標または商標です。
一太郎は、株式会社ジャストシステムの登録商標です。
OASYSは、富士通株式会社の登録商標です。
Adobe、Acrobat、PageMaker、およびPostScriptは、Adobe Systems Incorporated(アドビシステムズ社)の商標です。
Lotus、Lotus Domino、およびLotus SuperOffice(スーパーオフィス)は、米国IBM社の登録商標です。
QuarkXPressは、米国ならびに各国で登録されたQuark, Inc.とQuark関連会社の商標です。
Pentiumは、アメリカ合衆国およびその他の国におけるインテル コーポレーションまたはその子会社の登録商標です。
秘文は、日立ソフトウェアエンジニアリング株式会社の登録商標です。
本ソフトウェアは、the Independent JPEG Groupで作成されたコードの一部を利用しています。
上記以外の社名、または商品名等は各社の登録商標または商標です。
Xerox、Xeroxロゴ、およびFuji Xeroxロゴは、米国ゼロックス社の登録商標または商標です。
DocuWorksおよびドキュメントハンドリングは、富士ゼロックス株式会社の登録商標または商標です。
本書の内容は、予告なく変更することがありますので、ご了承願います。

Copyright(C) 1996-2018 Fuji Xerox Co., Ltd. All rights reserved.
管理番号: ME8867J1-3 1版